Are you the publisher? Claim or contact us about this channel


Embed this content in your HTML

Search

Report adult content:

click to rate:

Account: (login)

More Channels


Showcase


Channel Catalog


Channel Description:

Popular Discussion Threads in SAP liveCache Technology

older | 1 | 2 | 3 | (Page 4) | 5 | 6 | .... | 33 | newer

    0 0

    We are planning to refresh quality assurance(Q/A) systems  of ERP landscape and SCM 7.0(APO) landscape with the productive systems

    (Have done on ERP on regular basis, now APO landscape was also built up and is productive, too)

     

    I have read a lot of documents, but still have some  doubts about the best method:

    Best Practise Documents systemcopy (http://service.sap.com/solutionmanagerbp) + note 88543 copy of system landscapes)

    Note 457425 - Homogeneous liveCache copy using backup/restore

    Note 886103 - System Landscape Copy for SAP SCM

    Note 1015489 - Connection problems after system copy

    Note 1030857 - Report for additional update after system copy

     

    According note 886103, livecache is normally also copied with SCM system.

     

    Question 1) Could we also only copy the  SCM-PROD system to SCM Q/A and then initialise the Q/A livecache (after having changed tables in SCM system, which points to the right livecache on Q/A livecache server). I would appreciate getting experience from other customers.

     

    If we copy the livecache, too:

    We could use the method with backup/restore from note 457425.

    In Bestpractise Dok  Checklist for Recovery of SAP APO liveCache >= 7.4 I found:

    APO/SCM only

    Do not select “Restore database until a specified time.” If the liveCache instance is not completely

    recovered, inconsistencies might occur between the APO database and liveCache. SAP does not

    support synchronization using time stamps.

    Question 2: I am wondering if this is still valid (dokument is from 2005...) ?

    Normally we copy the systems with flashcopy/online backup method, so that the source systems are online always. We deactivate rfc connections, jobs etc on target system before starting the system

    If livecache doesn't support point in time recovery, how can we solve that ?  The SCM (APO) system should have the data of the same timestamp as ERP system. I would normally restore ERP, SCM and probably livecache to same timestamp, but if it is not possible to restore to a time stamp..... ?

     

    Question 3 to Note 886103:

    To adapt the liveCache table /sapapo/ordmap, you need to open a command prompt on the liveCache server and start xquery. Alternatively you could useSQL Studio.

     

    Enter: username/password/system name (sapr3/../LC-Target)

    Command: select LOGSYS, count(*) from "SAPR3"."/SAPAPO/ORDMAP" group by logsys

     

    For each LOGSYS that is displayed, the same mapping / changes have to be done as in BDLS. For example <APO-SOURCE>M001 => <APO-TARGET>M001

     

    Command: update "SAPR3"."/SAPAPO/ORDMAP" set logsys='<APOTARGET>M001'where logsys='<APO-SOURCE>M001'

     

    This will change the logical system name in /sapapo/ordmap to the target system.

    I only found an empty table SAPSR3./SAPAPO/ORDMAP in the SCM system but not in the livecache server.  Iis there a SAPR3 (or SAPSR3) schema  in the livecache ? I haven't found this user with the dbmgui....

     

    Any ideas are welcome...


    0 0

    Hello Experts,

     

    Whenever i execute LC10, i see 3 DB connections - LCA, LDA and LEA.

     

    I do have some basic questions which i couldnt find answers for:

     

    1. How to find out which DB connection is used in the system - LCA, LDA or LEA.

    Or all the three will be used for LC to be functional?

     

    2. If only LCA is used, how to uninstall or remove the connections for others?

     

    Thanks,

    Subbu


    0 0


    After system copy we are getting a livecache error when we want to de-initialize and initialize the planning areas.  Any ideas?livecache error.png


    0 0

    Hi,

     

    we are in the situation where we will move our APO system from an inhouse server, to a server provided by an external vendor.

     

    A question/issue has come up regarding live cache. We are on an old release 4.6 and live cache version 20, according to SAP newest version is 50 and they do not recommend to go lower than version 32.

     

    The idea is to move APO and forget the current live cache and rebuild it with the new version. For transactional data, can this be done by simply transferring data again from connected ERP systems or will we face new problems?

     

    Thanks,

    Lars


    0 0

    Hello All,

     

    I am using DB studio for the first time. I can trigger and successfully execute backups through DB Studio for my LC database. But I notice that it is writing to the default path - Run Directory : /sapdb/<SID>/data/wrk/<SID>. I must mention here that I am choosing the option of 'File' as my backup medium. Now I understand that the Run directory path is maintained in the parameter file <SID>.pah.

     

    My question over here is can I change this path to write to the file system which I have for backups. Is the run directory path linked to other executable which may have an impact if the path is changed. Also another question is , I noticed that it is asking for a file name every time I trigger a backup. So if I schedule this backup through DB13 by choosing the Livecache database , how do I adjust the name of the backup file for every occurrence of the backup.

     

    Thanks

     

    Surajit


    0 0

    Hi,

     

    we are migrating (with DMO) our SCM (APO) system with external liveCache (SapDB) to HANA with integrated liveCache.

     

    After SUM stops in phase "Restore liveCache" we run program /SAPAPO/OM_LC_DOWNLOAD_UPLOAD and executed steps "Load Master Data" and "UploadliveCache Data" without errors.

     

    After performing step 6. "Compare liveCache with Download" (in Section C) we get a lot of ( about 3.000) warnings in protocol (see also attached file):

     

    (...)

    Produktionsauftrag BO2922 (Eigenf.): Dates/times changed by up to 82801 seconds

    Produktionsauftrag BO2330 (Eigenf.): Dates/times changed by up to 54000 seconds

    Produktionsauftrag BO1865 (Eigenf.): Dates/times changed by up to 32400 seconds

    (..)

     

    Why is there such a big gap between liveCache and download?

     

    Kind regards

    Stefan


    0 0

    Hi Experts,

     

    I've requirement to change the order quantity of the receipt elements as proposed by the system, after we run the Product heuristic in RRP3 (i.e. the ability to change the system proposed quantities for certain receipt elements).

     

    I'm trying to make the required changes in BADI /SAPAPO/RRP_HEUR_DO~AFTER.

     

    I'm able to get all the order information via FM  /SAPAPO/OM_ORDER_GET_DATA and internal table IT_OUTPUTS contain the Receipt elements I want to modify.

     

    But I'm facing problem while changing this order.

    I'm trying to use FM  /SAPAPO/OM_ORDER_CHANGE, but getting different error messages in ET_RC table (I resolve one, it throws another at me).

     

    I've a few questions at this point:

    1. Is it even possible to change(modify) the order at this stage(during Product Heuristic)?

    2. If it is possible, then what all parameters should I export to the above FM. I've tried passing most of the internal tables as received from FM "/SAPAPO/OM_ORDER_GET_DATA", but currently I'm stuck at error OM181(No scheduler parameters were specified).

     

    This suggests to me that the order will be rescheduled completely, rather than just a small modification.

     

    3. So, is there any easy way to change orders in liveCache?

     

    Any help/clarity on this will be much appreciated.

     

    Thank you,

    Bhuvan


    0 0

    Hello Experts,

     

    Whenever i execute LC10, i see 3 DB connections - LCA, LDA and LEA.

     

    I do have some basic questions which i couldnt find answers for:

     

    1. How to find out which DB connection is used in the system - LCA, LDA or LEA.

    Or all the three will be used for LC to be functional?

     

    2. If only LCA is used, how to uninstall or remove the connections for others?

     

    Thanks,

    Subbu


    0 0
  • 08/18/14--06:05: Error while opening LC10
  • Hi All,

    We have installed live cache & SCM 7.0 in the same system & while opening LC10 it gives an error in DBMCLI or DBMSERVER.

    But am able to execute DBMCLI commands , Both DB 59 & RSTPTEST throws an erron in tp call.

    .

      Connect. test with "dbmcli db_state"                         Unsuccessful

      dbmcli_command_execute_error

      Error! Connection failed to node CA-INTRIGO02 for database LC1:

      tp error: tp=>sapparam: SAPSYSTEMNAME ne

      External program terminated with exit code 2

    . Connect. test with command mode "dbmrfc db_state"            Unsuccessful

      dbm_system_error

      Name and Server     : LC1 - CA-INTRIGO02

      DBMRFC Function     : DBM_EXECUTE

      Command             : db_state

      Error               : DBM Error

      Return Code         :        -11

      Error Message       : tp error: tp=>sapparam: SAPSYSTEMNAME ne

    . Connect. test with session mode "dbmrfc db_state"            Unsuccessful

      dbm_execute_error

      Name and Server     : LC1 - CA-INTRIGO02

      DBMRFC Function     : DBM_EXECUTE

      Command             : db_state

       Connect. test with "native SQL"  ( LCA )                     Successful




    DB Connect            Link to database failed

    Offline Call          connect failed


    0 0

    12-8-2014 1-25-19 PM.jpg
    Hello -

     

    I have been trying to fix this issue since liveCache does not want to start. Could someone please review and let me know what I may be able to do?


    0 0
  • 04/14/15--06:47: starting Livecache
  • Hello,

     

    Every time that Livecache is started the report SLCA_LCK_SYNCHOWNERS is executed.

     

    Starting the livecache with the different start options (LC10, report RSLVCSTART, from O.S level) this report is always executed?

     

     

    Regards.


    0 0

    Hi Livecache Experts,

     

    We recently had an issue with starting the livecache. I found out that when the livecache was stopped, they didn't stop the x_server process. When they tried to bring up the livecache, it won't come up. They tried to perform the x_server stop, kill sdb process then start x_server again but the livecache won't come up still.

     

    So I ended up restarting the livecache server itself then start the x_server - now everything is started cleanly. Then I was able to bring the livecache.

     

    My analysis on this is when they tried to bring up the livecache for the first time, it didn't come up since x_server wasn't stop and started cleanly. there is a kind of miscommunication between the two. Then even when you tried stopping and starting x_server after livecache start failure, it doesn't work because its already too late to do that since livecache doesn't recognize the "sdb" user/processes anymore. It made sense to me because that is the error we encountered when trying to bring up the livecache, we get "sdb user unknown"

     

    Only when we restarted the server itself and perform a clean start then it worked. Also have to rename the dbm.shi dbm.shm processes as mentioned in  https://scn.sap.com/thread/3262926

     

    Questions:

    1. Is it required to stop the x_server and kill sdb processes when you stop the livecache?

    2. What is their dependency on each other?

    3. What happens when x_server is not stopped then you try to bring up the livecache? (I want someone to elaborate what happens in the background.)

    4. Why is there a need to rename the dbm.shi and dbm.shm as mentioned in this thread - https://scn.sap.com/thread/3262926?

     

    Everything is working fine right now, I just wanted this incident to be documented with the correct information and raise awareness to prevent this type of issues to happen again.


    0 0
  • 09/24/14--06:27: LiveCache connection problem
  • Hello,

     

    We have a SCM 7.0 system with EHP 3 with a liveCache (MaxDB 7.9.08) .

     

    If I click the button "liveCache Monitoring with DBA Cockpit" in the TX LC10, I get the following error for each database connection (LCA, LDA and LEA) :

         

    LCA SQL not possible
    LCA SQL Error: 10709
    LCA Connection failed (RTE:[1] cannot connect to server socket) SBAC |
    LCA DBM not possible
    LCA Error when calling function module DBM_EXECUTE_SDB
    LCA Command:                                dbm_version
    LCA Name and Server     : LCD - <IP-Address>
    LCA Function            : DBM_EXECUTE
    LCA Command             : dbm_version
    LCA Error               : DBM Error
    LCA Return Code         :         -4
    LCA Error Message       : cannot connect to server socket
    LCA DBM Error 8  - DBM System Error

     

     

    In the TX SM21 you can see the error message below:

     

         Database error -10709 at CON

         > Connection failed (RTE:[1] cannot connect to server socket)

     

     

    Im Trace-File dev_w0 I found the following:

     

         Connect to LCA as SAPLCD with <IP-Address>-LCD

         Try to connect as SAPLCD/<pwd>@<IP-Address>-LCD on connection 1 ...

         *** ERROR => Connect to database failed, rc = -10709 (Connection failed (RTE:[1] cannot conn

         bmaxsql.cpp 607]

         {root-id=54217256A7094810E1008000AC110048}_{conn-id=00000000000000000000000000000000}_0

         ***LOG BY2=> sql error -10709 performing CON [dbds         919]

         ***LOG BY0=> Connection failed (RTE:[1] cannot connect to server socket) [dbds         919]

     

     

    I would like to mention, that I have maintained the liveCache Integration as follows:

     

         Name of Database Connection: LCA (or LDA or LEA)

         liveCache Name: LDA

         liveCache Server: here I tried with the IP-address and also with the physical hostname, but none of them worked

         DBM User:

              User Name: CONTROL

              Password:    xxx

     

          Standard liveCache User:

              User Name: SAPLCD

              Password:    xxx


    Furthermore, I have checked at database-level, the liveCache is up and running and the passwords are correct:


         dbmcli -d LCD -u control,<password> db_state

         OK

         State

         ONLINE

        

         dbmcli -d LCD -u saplcd,<password>

         dbmcli on LCD>



    But in the TX LC10 the buttons "Start liveCache" and "Stop liveCache" are watermarked.

     

    I have already tried to restart the liveCache and the SCM-system, but without success.


    In my opinion the cause is, that the liveCache cannot be reached from the SCM-system.

     

    Could you please advise?


    Thanks a lot in advance.


    Kind regards,

    Noémi





    0 0

    Dear Experts,

     

    We recently performed an activity of dropping the live cache and re-initializing it for one of our project requirements which is stated below.

     

    Requirement:There was a demerger happening for our client in which few of the asset companies within our Client were separating and forming a new company.

    Naming for old company - ABC and new company - XYZ.

     

    XYZ was shifting completely to a new system and they wanted us to clean all the data pertaining to ABC from their system.

    We used SLO to perform deletion of data belonging to ABC from the APO data base and to delete the data from live cache ,the live cache was dropped (which deleted ABC & XYZ data from live cache) and then reloaded from data base ( re- initialized the live cache).

    The following issues were faced after re-initialization of livecache.

    a)All the transactional data even belonging to XYZ was deleted from the system.

    b)While trying to load data in DP planning book , received error "key figure does not exist" and planning book could not be processed further.

    c)While running the planning area consistency check , received error "storage bucket profile does not exists in the live cache".

     

    Can anyone help on how to correct the issue if you had a similar situations in the past.Any suggestions would be helpful.

     

    Thanks


    0 0


    After system copy we are getting a livecache error when we want to de-initialize and initialize the planning areas.  Any ideas?livecache error.png


    0 0

    Hi,

     

    we are migrating (with DMO) our SCM (APO) system with external liveCache (SapDB) to HANA with integrated liveCache.

     

    After SUM stops in phase "Restore liveCache" we run program /SAPAPO/OM_LC_DOWNLOAD_UPLOAD and executed steps "Load Master Data" and "UploadliveCache Data" without errors.

     

    After performing step 6. "Compare liveCache with Download" (in Section C) we get a lot of ( about 3.000) warnings in protocol (see also attached file):

     

    (...)

    Produktionsauftrag BO2922 (Eigenf.): Dates/times changed by up to 82801 seconds

    Produktionsauftrag BO2330 (Eigenf.): Dates/times changed by up to 54000 seconds

    Produktionsauftrag BO1865 (Eigenf.): Dates/times changed by up to 32400 seconds

    (..)

     

    Why is there such a big gap between liveCache and download?

     

    Kind regards

    Stefan


    0 0
  • 12/22/14--05:46: Live cache upgrade errors
  • Hello,

     

    We are doing an upgrade on APO 4.1 to SCM 7.0 EHP2

     

    We reached a phase where we had to upgrade the Live Cache and its client.

    After the upgrade was done to 7.9 there are several errors in LC10.

     

    @0S\QInformation Message@ IGS is not available (RC=1). No charts will be displayed.

    @8O\QException@ LCA+ Exception CX_DBA_ADBC in class CL_SDB_ADBC method DBM_EXECUTE line 82 / RC=ADBC error

    @5C\QError Message@ LCA SQL not possible

     

     

    From DB59,

     

    1 DBSL Library Availability @01\QTest successful@

    2 Client Software Availability @01\QTest successful@

    3 Execute an external operating system command (DBMCLI) @01\QTest successful@

    4 Determine status using SQL connection @02\QAn error has occurred@

    4 RC:        0 @02\QAn error has occurred@

    4 Please check with SM50 the following work process:  4 @02\QAn error has occurred@

    5 Test the SQL connection (Native SQL at CON_NAME) @02\QAn error has occurred@

    5 sql_neg: no_connection @02\QAn error has occurred@

    5 Error creating a secondary database connection @02\QAn error has occurred@

    5 Set up of a secondary connection to the database system failed. It is possible that the data required for setting up the connect @02\QAn error has occurred@

    5 SQL code: @02\QAn error has occurred@

    5 o shared library found for the database with ID LCA @02\QAn error has occurred@

    5 Please check with SM50 the following work process:  4 @02\QAn error has occurred@

     

    DBM commands,

     

    lcsadm@apo-l-lcs-02 % dbmcli inst_enum

    OK

    7.9.07.09    /sapdb/LCS/db

    lcsadm@apo-l-lcs-02 % dbmcli db_enum

    OK

    LCS    /sapdb/LCS/db                          7.9.07.09      fast    running

    LCS    /sapdb/LCS/db                          7.9.07.09      quick  offline

    LCS    /sapdb/LCS/db                          7.9.07.09      slow    offline

    LCS    /sapdb/LCS/db                          7.9.07.09      test    offline

    lcsadm@apo-l-lcs-02 % xinstinfo LCS

    IndepData          : /sapdb/data

    IndepPrograms      : /sapdb/programs

    InstallationPath    : /sapdb/LCS/db

    Kernelversion      : KERNEL    7.9.07  BUILD 009-123-242-971

    Rundirectory        : /sapdb/data/wrk/LCS 10:51

    lcsadm@apo-l-lcs-02 % dbmcli -d LCS -u control,consdbaz db_state

    OK

    State

    ONLINE

     

     

     

    Can you help us?


    0 0

    Hello All,

     

    I am using DB studio for the first time. I can trigger and successfully execute backups through DB Studio for my LC database. But I notice that it is writing to the default path - Run Directory : /sapdb/<SID>/data/wrk/<SID>. I must mention here that I am choosing the option of 'File' as my backup medium. Now I understand that the Run directory path is maintained in the parameter file <SID>.pah.

     

    My question over here is can I change this path to write to the file system which I have for backups. Is the run directory path linked to other executable which may have an impact if the path is changed. Also another question is , I noticed that it is asking for a file name every time I trigger a backup. So if I schedule this backup through DB13 by choosing the Livecache database , how do I adjust the name of the backup file for every occurrence of the backup.

     

    Thanks

     

    Surajit


    0 0
  • 02/08/15--09:26: Livecache log files
  • Hi ,

     

    Please let me know the live cache log files and location of the same.

     

    I would need them to analyze livecache issues during the upgrade and startup/performance related problems.

     

    any help is much appreciated.

     

    Thanks in advance


    0 0

    Hi,

     

    we are migrating (with DMO) our SCM (APO) system with external liveCache (SapDB) to HANA with integrated liveCache.

     

    After SUM stops in phase "Restore liveCache" we run program /SAPAPO/OM_LC_DOWNLOAD_UPLOAD and executed steps "Load Master Data" and "UploadliveCache Data" without errors.

     

    After performing step 6. "Compare liveCache with Download" (in Section C) we get a lot of ( about 3.000) warnings in protocol (see also attached file):

     

    (...)

    Produktionsauftrag BO2922 (Eigenf.): Dates/times changed by up to 82801 seconds

    Produktionsauftrag BO2330 (Eigenf.): Dates/times changed by up to 54000 seconds

    Produktionsauftrag BO1865 (Eigenf.): Dates/times changed by up to 32400 seconds

    (..)

     

    Why is there such a big gap between liveCache and download?

     

    Kind regards

    Stefan


older | 1 | 2 | 3 | (Page 4) | 5 | 6 | .... | 33 | newer